Voyage MPD には、高度にカスタマイズされた「シンさんバージョン」があります。 http://blog.naver.com/manishin/ からリンクをつたってダウンロードできます。

弊社から今年の夏以降に出荷された ALIX.3D2 では、この「シンさんバージョン」は起動しません。今年の夏以前に出荷された ALIX.3D2 では正常に起動できます。問題は「オーバークロック」で、今年の夏以降に出荷された ALIX.3D2 は「オーバークロック」で落ちます。以下は 0907版の「シンさんバージョン」の起動ログの抜粋です。

 

[ ok ] Starting OpenBSD Secure Shell server: sshd.
[ ok ] Starting HPA's tftpd: in.tftpd.
Setting up X font server socket directory /tmp/.font-unix...done.
Starting X font server: xfs.
0000:00:0f.4 @0d ff
0000:00:0f.5 @0d ff
[   22.130278] ------------[ cut here ]------------
[   22.145068] WARNING: at kernel/sched.c:4473 add_preempt_count+0x59/0x6f()
[   22.166760] Modules linked in: lirc_dev fuse ipv6 ledtrig_timer ledtrig_heartbeat geode_aes
scx200_acb i2c_core cs5535_mfgpt geode_rng rng_core xfs exportfs ata_generic pata_cs5536 pata_amd
libata ide_pci_generic cs5536 ohci_hcd ssb ehci_hcd usbcore via_rhine amd74xx usb_common
 [last unloaded: scsi_wait_scan]
[   22.255720] Pid: 2126, comm: wrmsr Not tainted 3.2.28-rt42 #1
[   22.274093] Call Trace:
[   22.281934]  [] warn_slowpath_common+0x48/0x5d
[   22.298921]  [] ? add_preempt_count+0x59/0x6f
[   22.315623]  [] ? bad_area+0x9/0x3a
[   22.329563]  [] ? bad_area+0x9/0x3a
[   22.343509]  [] warn_slowpath_null+0xf/0x13
[   22.359674]  [] add_preempt_count+0x59/0x6f
[   22.375845]  [] search_module_extables+0x13/0x7a
[   22.393391]  [] ? bad_area+0x9/0x3a
[   22.407319]  [] search_exception_tables+0x22/0x25
[   22.425148]  [] fixup_exception+0xe/0x40
[   22.440476]  [] no_context+0x15/0x123
[   22.455008]  [] ? unlock_slab_and_free_delayed.isra.50+0x66/0x68
[   22.476997]  [] __bad_area_nosemaphore+0xf7/0xff
[   22.494546]  [] ? vmalloc_sync_all+0xf0/0xf0
[   22.510987]  [] bad_area_nosemaphore+0xd/0x10
[   22.527703]  [] do_page_fault+0x14b/0x330
[   22.543329]  [] ? ____call_usermodehelper+0xdc/0xdc
[   22.561699]  [] ? call_usermodehelper_setup+0x51/0x51
[   22.580669]  [] ? vmalloc_sync_all+0xf0/0xf0
[   22.597113]  [] error_code+0x58/0x60
[   22.611322] ---[ end trace 0000000000000002 ]---

これを回避するには「オーバークロック」機能を止めます。/etc/rc.local の以下の行をコメントアウトします。

wrmsr 0x4c000014 0x69ec3de012e # 533/466 + PCI_SEMI_SYNC_MODE

または、シンさんが「オーバークロック」機能を止めた 1022版をアップロードされていますのでそれをダウンロードしてください。

ファイルは 121022_2-V085-xfs-3232rt48-mpd_yan-clk_nor-alsa1025-pwr_btn-dsd-2share.rar です。